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1 Introduction
The purpose of this document is to demonstrate the usage of the Process-Interaction-
Model (PIM) concept [1] in the modeling software PROMOT [2, 3]. PROMOT
is a powerful tool for constructing dynamic (quantitative) and logical (qualitative)
models for systems biology and chemical engineering. More information on the
construction of these model types can be found in separate tutorials.

The Start-Up Guide at hand briefly explains the basic steps in constructing and
converting PIMs in PROMOT. A small example model which is introduced in [1] is
used to demonstrate how to use the concept in PROMOT. The document is intended
to be used as a jump start guide for the non-technically inclined and hence does not
dwell into the background architecture or design of the software.
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2 Preliminary: Getting PROMOT setup for the first
use

2.1 How do I install PROMOT?
Usually PROMOT is used from the text editor EMACS. Therefore the line
(load "/usr/local/promot/promot/emacs/promot")must be inserted into your
personal /̃.emacs1.
If PROMOT was installed into a different location /usr/local/promot/promot

has to be substituted by your installation directory. This applies also for the follow-
ing sections.

1. Open a new terminal window like konsole from the window manager. Usu-
ally there is a control panel in KDE and on this control panel you can find a
screen-icon. Click on this icon one time, and you will get a terminal.

2. Type emacs /̃.emacs and hit the return (enter) key. In all following com-
mands we will assume implicitly that you hit return.

3. Move the cursor to the beginning of the file (it may be empty) and type:
(load "/usr/local/promot/promot/emacs/promot")2. Save the file by
the menu bar File > Save or by pressing the keys C-x C-s 3.

4. Exit the EMACS by the menu bar File > Exit Emacs or by pressing C-x C-c.

At the next start of EMACS, PROMOT will be available.

2.2 How can I start PROMOT?
2.2.1 Using the console

1. Use your Terminal window or start a new one as described in 2.1.

2. Type ”/usr/local/promot/promot/scripts/promot” and ProMoT will get started.

1 If the tilde ‘˜’ seems to be broken on a German (QWERTZU) Keyboard, it is possibly necessary
to type the tilde key followed by a space ‘ ’. Tilde is used in UNIX and Linux to refer to your personal
home directory instead of typing the pathname all the time.

2The .emacs is a configuration file for the start of the text editor EMACS. It is executed every
time EMACS starts. By adding this line, some new entries are added to the menu of EMACS to start
PROMOT.

3C-x C-s is the EMACS notation for pressing “Control” and the “x” key at the same time followed
by “Control” and the “s” key.
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2.2.2 Using the text editor EMACS

1. Use your Terminal window or start a new one as described in 2.1.

2. Type emacs and EMACS starts up.

3. Select in the menu of EMACS: Promot > Start Promot.

4. The BROWSER window of PROMOT shows up.

Inside EMACS there are now two windows, showing useful information about the
PROMOT system: *promot-server* and *compilation*. It is also possible to
work interactively with the *promot-server*.

2.3 Where can I find further information?
More detailed documentation, particularly covering the application of PROMOT for
logical and dynamic models and the PROMOT manual can be found at the PROMOT
web-site:
http://www.mpi-magdeburg.mpg.de/projects/promot/docu.html.

4

http://www.mpi-magdeburg.mpg.de/projects/promot/docu.html


3 Getting Started: A look at the PROMOT GUI
Upon starting PROMOT the default (the bare necessities that compromise the pro-
gram) PROMOT GUI4 loads the PROMOT BROWSER, which is the main window of
PROMOT, see Figure 1. In the following the PROMOT BROWSER is simply called
BROWSER. The BROWSER contains six menus (File, Edit, View, Options, Tools
and Help) with drop down selections and allows the user to find modeling entities,
start graphical and textual editors as well as to load and save files.
There are two distinct areas of the BROWSER, a left panel containing a tree that
shows the class hierarchy with all the modeling entities currently loaded and a right
panel where, if desired, the MDL source code of the currently selected class can be
viewed. (If you do not see the right panel we explain how to view this in a bit).
The tree can be expanded and compacted by clicking the handle buttons to the left
of each entity, where subclasses are shown in the subtree of the regarding super-
classes. For example the default classes of PROMOT, as shown in Figure 1, are
subclasses of the modeling-entity and include:

1. behavioral-modeling-entity
> continuous-modeling-entity > > equation / variable
> discrete-modeling-entity > > place / transition

2. structural-modeling-entity
> module
> terminal

For the first-time user the most important modeling entities are located in the subtree
of the structural-modeling-entity > module. The file tree also has a context-menu
(which can be viewed upon right-clicking) for each entity within it and is used for
starting most editing actions. To go to the structural-modeling-entity > module:

1. Click the handle button to the left of the folder icon of structural-modeling-
entity.

2. Now there are two basic classes in view, module and terminal. There are
currently no modeling-entities defined.

3. To view the context-menu right click on the modeling entity.

4. The BROWSER enables the user to view either just the left panel (with the
file tree) or both the left panel and the right panel (with the source code of
the currently selected class). To switch back and forth between modes click

4GUI is an acronym and stands for Graphical User Interface, i.e. the windows, menus items,
scroll bars, etc. that frames the main content that PROMOT presents as a working environment.
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Figure 1: The window of the BROWSER.

on the BROWSER menu View and select the check-box Show Quickview.
With this option enabled the corresponding MDL source code of the currently
selected class will be displayed in the right panel of the BROWSER. PROMOT
models are written in MDL, however the modeling language MDL is beyond
the scope of this tutorial.
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4 The library for the PIM concept
A specialized library has been designed for the PIM concept. It contains the main
building blocks needed to set up a PIM. To load the library into PROMOT choose
from the menu File > Open > Process-Interaction Library. In the tree the classes
molecule, process-interaction-library and process-interaction-model will appear as
subclasses of module.

The building blocks tailored for the PIM concept are subclasses of process-
interaction-library and show up by expanding the subtree. Processes and interac-
tions are needed to specify the graph of a PIM (see [1]). The class interaction is
specialized by the classes unidirectional and bidirectional. The class process has
the three subclasses binding, modification and structure (see Figure 2). For differ-
ent numbers of incoming edges process classes are available from the library. They
can be viewed by expanding the subtrees of modification and binding. A number
in the class names indicates the number of incoming edges (i.e. how many other
processes have an influence on the current process). Furthermore different process
classes have to be used depending on whether the process has outgoing edges (i.e.
influences other processes) or not. Processes with outgoing edges are indicated by
the ending out in the class name. For example the class modification3 out has to
be used to model a process which is influenced by three other processes and has an
influence on one or more other processes.

Figure 2: The left screenshot shows the PROMOT BROWSER with loaded library for the PIM
concept. The class for a molecule r is selected and its MDL code is shown in the right panel. Molecule
r contains three sites (specified as variables). The right screenshot shows the VISUAL EDITOR with
an example PIM.
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5 An example model
To set up a model we have to create a model class. Therefore right click to the
class process-interaction-model and choose from the context menu Add Subclass....
Type a name for the class in the appearing dialog (for example my-pim). To visu-
ally edit the model start the VISUAL EDITOR by double clicking to the class my-
pim. Now processes and interactions can be added to the model by drag and drop
from the tree in the BROWSER to the construction area in the VISUAL EDITOR.
Thereby only non-abstract classes of the library have to be used; they are visualized
by blue symbols next to the tree-nodes in the BROWSER. After adding elements to
the construction area their terminals (circles on the elements) can be connected by
dragging lines between them. Molecule and site assignments and parameter tables
of processes can be edited in specialized dialogs which can be obtained from the
context menu of nodes (right click to nodes in the VISUAL EDITOR).

A detailed description of how to set up a complete model from scratch in a four-
step process (as described in [1]) can be found in the section ’How to set up a PIM’
at the end of this document. In [1] we argue that a PIM is a common representation
of a qualitative and a quantitative model of the same signaling system. Conse-
quently models of both types can be generated from a PIM and we consider this
as the main functionality supported by our software implementation. Therefore we
start with a description of this functionality by using the small example presented
in [1]: To load the model click File > Open > Model... and go to the directory
promot\kb\SignalTransd\PIM in your PROMOT installation and select the file
named PIM-example.mdl.

Now the three classes a,b and r have been loaded as subclasses of molecule and
the class example-manuscript has been created as a subclass of process-interaction-
model. To view the content of the class we can open it in the VISUAL EDITOR by
double clicking to the class example-manuscript. The example PIM contains four
processes: two binding processes visualized by green circles and two modification
processes visualized by blue circles (see Figure 2). They are connected by the
different types of interactions. How to set up and edit this example PIM is described
in the section ‘How to set up a PIM’.

6 Exporting reaction rules from a PIM
To export reaction rules for the small example model in BioNetGen Language
(BNGL) select the class example-manuscript in the BROWSER and choose from
the menu Tools > Convert Into BNGL Rules. Now you can choose where to save
the BNGL-file. The generated file is ready for use in the software BioNetGen [4].
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7 Generating a modular logical model from a PIM
To convert the example PIM into a logical model select the class example-manuscript
in the BROWSER and choose from the menu Tools > Convert Into Logical Model.

Now additional classes are loaded into PROMOT. The subclasses of struct-
library belong to the standard library for logical modeling [5] plus a few additional
classes for site-specific logical modeling. Several classes are created for the site-
specific logical model; all of them can be found as subclasses of struct-model (see
Figure 3):

Figure 3: On the left the BROWSER with loaded PIM and the corresponding logical model is
shown. The right screenshot shows the VISUAL EDITOR with the logical class for the molecule
r log. Blue and green filled rounded rectangles denote species for the modification and binding sites
of the molecule, a half filled rounded rectangle represents the basal activity and filled orange circles
contain information about the logical connection of the species.

• The main class for the model is named example-manuscript-logical. This
class is automatically opened in the VISUAL EDITOR. Wait until the red
boxes in the VISUAL EDITOR disappear. You can apply a layout to the ele-
ments by choosing Layout > Spring Layout... from the menu of the VISUAL

EDITOR.

• One module has been created for each of the molecules occurring in the PIM
(in our case a log, b log and r log). You can open the modules by double
clicking to them in the VISUAL EDITOR. Figure 3 exemplarily shows the
class r log in the VISUAL EDITOR on the right. Each of these classes con-
tains species for the sites of the molecules, a species for the basal activity
and further elements containing information about the logical connection of
the species (obtained from the parameter tables of process nodes in the PIM,
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see [1]). All molecule classes can be found in the BROWSER tree as sub-
classes of molecule-logical.

• The elements containing the logical functions (e.g. clg r log p1 in Figure 3)
can also be opened in the VISUAL EDITOR by double clicking to them. These
classes contain the logical functions among the species in the logical network
utilizing the basic elements AND, NOT and OR and can be found as sub-
classes of clg-2 to clg-6 in the BROWSER tree.

The logical model is ready for analysis in the software CellNetAnalyzer [6]. To ex-
port the model, select the model class (example-manuscript logical) in the BROWSER

and choose File > Export > Output To CNA.5

To get a graphical representation of the model PROMOT comprises a special-
ized GUI component, called VISUAL EXPLORER. It is well suited for the visualiza-
tion and exploration of (modular) models. To start the VISUAL EXPLORER select
a model class (e.g. the class example-manuscript logical) in the BROWSER, right
click to it and choose from the context-menu Visual Explorer.

8 How to set up a PIM
In this section we will describe how a PIM can be set up from scratch. First we have
to delete all classes currently loaded in PROMOT; therefore choose Edit > Delete
All from the BROWSER menu. Load the specialized library for the PIM concept by
choosing File > Open > Process-Interaction Library.

In the following we will describe how to set up the PIM which is schematically
shown in Figure 4 in four main steps.

1. Definition of molecules and sites: Each molecule which is involved in the signal-
ing system is set up as a class and contains information about contained sites. To
create a new molecule class select the class molecule in the BROWSER tree and
choose from the menu Tools > Create Class For Molecule.... Now a wizard starts
which guides you to create a class. Create the following three classes:

• a with the site b1 (i.e. protein name: a, number of sites: 1)

• b with the site b1

• r with the sites b1, p1 and p2
(If you cannot see all name fields enlarge the window).

5Documentation to the analysis of logical models can be obtained from
http://www.mpi-magdeburg.mpg.de/projects/cna/cna.html
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Figure 4: The small example PIM comprises four processes: the binding of ’A’ and ’R’ (process 1)
two modifications of ’R’ (processes 2 and 3) and the binding of ’B’ to ’R’ (process 4). Numbered
circles represent the process nodes. Appropriate molecules and sites are indicated in square brackets
above the nodes. Nodes are connected by directed edges representing the interactions and each node
has an assigned parameter table. The three involved molecules A, B and R and their sites are listed
in the gray box.

2. Definition of processes: First we need to define a model class. Right click to the
class process-interaction-model and choose Add Subclass from the context-menu.
Type a name for the class in the appearing dialog (for example my-pim). In the next
step we want to edit the class in a visual manner. To start the VISUAL EDITOR you
can either double click to the class my-pim or choose Visual Edit from the context-
menu of the class. In the VISUAL EDITOR choose Edit > Set Module Size from
the menu and type 600 and 400 as values for width and height.
Now we want to add the four process nodes (see Figure 4). Therefore go back to the
BROWSER and expand the subtrees of the library classes binding and modification.
The processes can be added to the model by drag and drop from the tree in the
BROWSER to the construction area in the VISUAL EDITOR. Thereby the class is
instantiated and the instance is used as a part of the currently edited class.

• Drag and drop the class binding0 out from the BROWSER tree to the con-
struction area. To rename the node press the “Space” key, type the new name
(choose ‘bind1’) and press “Enter” to confirm.

• Add an instance of the class modification2 out and rename it to ‘mod2’.

• Add an instance of the class binding1 and rename it to ‘bind4’.

• Add an instance of the class modification1 and rename it to ‘mod3’.

Assignment of involved molecules and sites to process nodes:
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• Right click to the node ‘bind1’ and choose from the context-menu Set Mole-
cules/Sites For Process. The dialog will offer two assignments for the bind-
ing process, choose ‘a.b1’ and ‘r.b1’. The list of molecules and sites is gen-
erated from the predefined molecule classes.

• Now assign ‘r.p1’ to ‘mod2’. The dialog will offer one assignment for the
modification process.

• Assign ‘r.p1’ and ‘b.b1’ to ‘bind4’.

• Assign ‘r.p2’ to ‘mod3’.

3. Connection of processes by interactions:

• Drag and drop the class unidirectional from the BROWSER tree to the con-
struction area of the VISUAL EDITOR; rename the node to ‘uni’ and connect
its input terminal to the output terminal of the process node ‘bind1’ by drag-
ging a line from one terminal to the other (Terminals of the type input are
shown as light blue circles on the nodes, output terminals are dark blue cir-
cles). Then connect the output terminal of ‘uni’ to the left input terminal of
the node ‘mod2’.

• Add an instance of the class bidirectional, rename it to ‘bi’ and connect its
input terminal to the other input terminal of ‘mod2’. Connect the output ter-
minal to the input terminal of ‘mod3’.

• Add an instance of the class unidirectional, rename it to ‘uni aon’ and con-
nect its input terminal to the output terminal of ‘mod2’. Connect the output
terminal of ‘uni aon’ to the input terminal of ‘bind4’. To set this interaction
as an All-Or-None interaction open the VARIABLES DIALOG by right click-
ing to the node ‘uni aon’ and choosing Edit Details from the context-menu.
In the table of the appearing dialog set the value of aon to ‘1’ and Save And
Close.

4. Assignment of parameters and thresholds to processes:

• Right click to the process node ‘bind1’ and choose Get Parameter Table
For Process from the context-menu. Enter the value ‘5.0’ for the forward
rate constant (k forw), the value ‘3.0’ for ‘Threshold 1’ and the value ‘4.0’
for ‘Threshold 2’. Now press the button Calculate Keq and Boolean to
calculate the equilibrium parameter as quotient of forward and backward rate
constant and discretize this equilibrium parameter. Then Save And Close. In
the last column the values ’1.0’, ’0.0’ and ’2.0’ can occur, where the value
’2.0’ stands for ’unknown’. The handling of the three valued logic resulting
from the discretization is described in the next section.
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• Open the parameter table dialog for ‘mod2’. This process has two inputs and
hence four rows for parameters. Enter the following values in the column of
‘k forw’: ‘0.9’, ‘5.5’, ‘6.0’, ‘20.0’ and the following values in the column
of ‘k backw’: ‘0.9’, ‘1.1’, ‘1.2’, ‘1.0’. Set the thresholds to ‘3.0’ and ‘4.0’
as for process ‘bind1’. Then again, calculate equilibrium parameter and the
Boolean value and Save And Close.

• Open the parameter table dialog for ‘bind4’. This process has one input and
hence two rows for parameters. Enter the following values in the column of
‘k forw’: ‘1.0’, ‘4.8’ and the following values in the column of ‘k backw’:
‘1.0’, ‘0.8’. Set the thresholds to ‘3.0’ and ‘4.0’. Then again, calculate equi-
librium parameter and the Boolean value and Save And Close.

• Open the parameter table dialog for ‘mod3’. This process has one input and
hence two rows for parameters. Enter the following values in the column of
’k forw’: ‘0.9’, ‘8.8’ and the following values in the column of ‘k backw’:
‘0.45’, ‘1.1’. Set the thresholds to ‘3.0’ and ‘4.0’. Then again, calculate
equilibrium parameter and the Boolean value and Save And Close.

Now the PIM is fully specified and can be converted into a modular logical model
or reaction rules can be exported as described above.

8.1 Handling the three valued logic
As described in [1] two thresholds are used to discretize the equilibrium parameter.
If the value of the equilibrium parameter lies between the two specified thresholds,
the value ’2.0’ is used to indicate an unknown value in the output column of the
parameter table of a process node. This value can not be used in the subsequent
automatic calculation of the Boolean function but is transferred to the clg classes of
the logical model. These classes are the elements which contain information about
the logical connections among species (see section ’Generating a modular logical
model from a PIM’).

In the logical model you can either visually construct the logical function using
elements from the struct-library. Thereby you can preserve the three valued logic.6

If a two valued logic should be used you can edit the values by right clicking to
the corresponding clg class and choose Edit Source from the context menu. After
changing all values of the parameter ’boolean’ to ’0.0’ and ’1.0’ you can calculate
the function by selecting the class clg and choosing from the BROWSER menu Tools

6The software CELLNETANALYZER provides functionality for the analysis of models containing
a three valued logic. How this can be done is described in a separate tutorial for logical modeling.
This can be obtained from http://www.mpi-magdeburg.mpg.de/projects/promot/docu.html
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> Find Boolean Function. Manually changing the ’unknown’ values to ’0.0’ or
’1.0’ in the logical model corresponds to changing the threshold values in the PIM.
Changing threshold values preserves consistency of the logical model and the PIM
and is therefore the preferred method.
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