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1 Introduction
The purpose of this tutorial is to introduce the PROMOT [1][2] interface to new
users and to act as a guidance for becoming more familiar with the process of con-
structing logical models in PROMOT. PROMOT is also a tool used for constructing
dynamic quantitative models and more information on this process can be found in
a separate tutorial. This tutorial explains the basic components of PROMOT and
uses the example of building a small simple modular model “toymodel” to enable
one to become more comfortable with the process. For simplicities sake it does
not dwell into the background architecture or design of the software, but is rather
intended to be used as a jump start guide for the non-technically inclined.
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2 Preliminary: Getting PROMOT setup for the first
use

2.1 How do I install PROMOT?
Usually PROMOT is used from the text editor EMACS. Therefore the line
(load "/usr/local/promot/promot/emacs/promot")must be inserted into your
personal /̃.emacs1.
If PROMOT was installed into a different location /usr/local/promot/promot

has to be substituted by your installation directory. This applies also for the follow-
ing sections.

1. Open a new terminal window like konsole from the window manager. Usu-
ally there is a control panel in KDE and on this control panel you can find a
screen-icon. Click on this icon one time, and you will get a terminal.

2. Type emacs /̃.emacs and hit the return (enter) key. In all following com-
mands we will assume implicitly that you hit return.

3. Move the cursor to the beginning of the file (it may be empty) and type:
(load "/usr/local/promot/promot/emacs/promot")2. Save the file by
the menu bar File > Save or by pressing the keys C-x C-s 3.

4. Exit the EMACS by the menu bar File > Exit Emacs or by pressing C-x C-c.

At the next start of EMACS, PROMOT will be available.

2.2 How can I start PROMOT?
2.2.1 Using the console

1. Use your Terminal window or start a new one as described in 2.1.

2. Type ”/usr/local/promot/promot/scripts/promot” and ProMoT will get started.

1 If the tilde ‘˜’ seems to be broken on a German (QWERTZU) Keyboard, it is possibly necessary
to type the tilde key followed by a space ‘ ’. Tilde is used in UNIX and Linux to refer to your personal
home directory instead of typing the pathname all the time.

2The .emacs is a configuration file for the start of the text editor EMACS. It is executed every
time EMACS starts. By adding this line, some new entries are added to the menu of EMACS to start
PROMOT.

3C-x C-s is the EMACS notation for pressing “Control” and the “x” key at the same time followed
by “Control” and the “s” key.
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2.2.2 Using the text editor EMACS

1. Use your Terminal window or start a new one as described in 2.1.

2. Type emacs and EMACS starts up.

3. Select in the menu of EMACS: Promot > Start Promot.

4. The BROWSER window of PROMOT shows up.

Inside EMACS there are now two windows, showing useful information about the
PROMOT system: *promot-server* and *compilation*. It is also possible to
work interactively with the *promot-server*.

2.3 Where can I find further information?
More detailed documentation, particularly covering the application of PROMOT for
logical and dynamic models and the PROMOT manual can be found at the PROMOT
web-site:
http://www.mpi-magdeburg.mpg.de/projects/promot/docu.html.
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3 Getting Started: A look at the PROMOT GUI
Upon starting PROMOT the default (the bare necessities that compromise the pro-
gram) PROMOT GUI4 loads the PROMOT BROWSER, which is the main window of
PROMOT, see Figure 1. In the following the PROMOT BROWSER is simply called
BROWSER. The BROWSER contains six menus (File, Edit, View, Options, Tools
and Help) with drop down selections and allows the user to find modeling entities,
start graphical and textual editors as well as to load and save files.
There are two distinct areas of the BROWSER, a left panel containing a tree that
shows the class hierarchy with all the modeling entities currently loaded and a right
panel where, if desired, the .MDL source code of the currently selected class can
be viewed. (If you do not see the right panel we explain how to view this in a bit).
The tree can be expanded and compacted by clicking the handle buttons to the left
of each entity, where subclasses are shown in the subtree of the regarding super-
classes. For example the default classes of PROMOT, as shown in Figure 1, are
subclasses of the modeling-entity and include:

1. behavioral-modeling-entity
> continuous-modeling-entity > > equation / variable
> discrete-modeling-entity > > place / transition

2. structural-modeling-entity
> module
> terminal

For the first-time user the most important modeling entities are located in the subtree
of the structural-modeling-entity > module. The file tree also has a context-menu
(which can be viewed upon right-clicking) for each entity within it and is used for
starting most editing actions. To go to the structural-modeling-entity > module:

1. Click the handle button to the left of the folder icon of structural-modeling-
entity.

2. Now there are two basic classes in view, module and terminal. There are
currently no modeling-entities defined.

3. To view the context-menu right click on the modeling entity.

4. The BROWSER enables the user to view either just the left panel (with the
file tree) or both the left panel and the right panel (with the source code of
the currently selected class). To switch back and forth between modes click

4GUI is an acronym and stands for Graphical User Interface, i.e. the windows, menus items,
scroll bars, etc. that frames the main content that PROMOT presents as a working environment.
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Right Panel
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Class Tree

Figure 1: The window of the PROMOT BROWSER.

on the BROWSER menu View and select the check-box Show Quickview.
With this option enabled the corresponding .MDL source code of the currently
selected class will be displayed in the right panel of the BROWSER. PROMOT
models are written in .MDL, however the modeling language .MDL is beyond
the scope of this tutorial.
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4 Building Your First Model: toymodel

4.1 Creating Submodules
The following is a step-by-step tutorial to creating a simple hierarchical model using
PROMOT. The name of the whole model will be toymodel and will contain the
submodules (subclasses) cell, whole model, and nucleus, which represent certain
levels of a cell that are commonly examined when modeling a signal transduction
pathway.

1. Start PROMOT and expand the structural-modeling-entity with the left handle
button to view the module subclass.

2. Right click on module and click on Add Subclass, as seen here in Figure 2.
A window pops up asking to name the new subclass. Click within the text
area of the pop-up window and type in the desired name for the model. (In
our case type in: toymodel).

Figure 2: PROMOT BROWSER Window: Adding a Subclass

3. Click OK.

4. The naming pop-up window will disappear and a handle button will now ap-
pear next to the structural-modeling-entity > module in the BROWSER. Click
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on the handle button to expand the module tree. There you will see the sub-
class we just added as “toymodel”.

5. One of PROMOT s attributes is its ability to construct and handle models built
in a modular style. Modules are attractive in modeling for purposes beyond
the scope of this tutorial, but with this in mind let our first example include
this approach and let us create the submodules as discussed above:

• Right click on the toymodel and click on Add Subclass (as done in step
2 above, but under toymodel instead of module) but this time naming
the subclass cell. Repeat this step to add the subclasses whole model
and nucleus as well, being sure to right click and add the submodule
under the toymodel.

6. Different types of classes can be specified in PROMOT.

• abstract classes: the default type for abstract library elements and
modules.

• non-abstract classes: these are specific library elements and model
parts. The source code of the class contains the following line:

:PROPERTIES

(("abstract" :VALUE "no"))

• executable classes: these contain complete models, which can be
exported to a simulation or analysis environment. The source code of
the class contains the following line:

:PROPERTIES

(("model" :VALUE "yes"))

At the moment the main purpose is a different visualization of the classes in
the BROWSER. The internal class module is an abstract class (see Figure 2).
You can change these boolean values by actions in the context-menu of a
tree-node in the BROWSER: Change Property > Abstract or > Model.

7. You can Undo/Redo every action you’ve made in the BROWSER except delet-
ing all classes. Try to undo/redo the “Add Subclass”-Action by clicking Edit
> Undo and Edit > Redo respectively. Alternatively you can press “Control”
+ “Z” and “Control” + “ Y”.
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4.2 Saving Files
Now let us save things before we get to the building part:

1. First it is recommended to make a folder where you will save all your files
from PROMOT. In your home directory (or directory of your choice) make a
folder called promot.

2. To make this directory:

(a) Open a new shell terminal window.

(b) Make the directory by typing: mkdir promot.
(c) Change to that directory by typing: cd promot.

3. Now that we have the main directory for all future model and analysis files
let us create another directory for the toymodel example we are in the process
of building. Using the same shell we just used to create the promot directory,
under the /promot]> directory make another directory called toymodel to
save all the files associated with this example in:

(a) in the /promot]> directory type: mkdir toymodel
(b) change to that directory by typing: cd toymodel

4. Now that we have a directory for this project within our promot folder we are
ready to save the files:

(a) Click on the superclass (i.e. toymodel ) of all the submodules (i.e. cell,
nucleus, whole model ) and go to the menu Edit > Select > Select
Subclasses and click on this menu-entry.

(b) Then go to: File > Save Selected Classes and save the .MDL file in the
toymodel directory just created named toymodel.mdl.

(c) Then select each subclass separately and save them each separately in
the same directory.5

(d) One may also want to delete a class or load a different class into PRO-
MOT. Since we have not started building a model yet, lets try this to
become familiar with the process.

5Note: This step is not necessary but makes working with individual parts of the model easier
until the whole thing is complete.
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• To delete a model (let us delete cell as an example): Click on the
cell module in the left panel of the BROWSER, then right click on
it and from the context-menu select Delete. The cell module will
disappear from the BROWSER but its corresponding .MDL source
code will still be in the toymodel directory you saved it in previ-
ously. Now lets reload the file.
• To load a model: From the BROWSER menu go to: File > Open >

Model... and go to the toymodel directory and select the file named
cell. Then click on Open. The cell module will then load back into
the PROMOT user interface.

4.3 Loading PROMOT Library Elements
Before we begin the building process we need to load the building components of
PROMOT, this is called the ProMoT library:
To do this you will need an initial library file from PROMOT6 which includes logical
components for building the models, such as the gates, compounds and connecting
elements.

1. Load this file into PROMOT by going to File > Open > Logical Library.

2. Under the left panel in the BROWSER the classes struct-library and struct-
model will appear as subclasses of module.

3. Click on the handle button to the left of the struct-library to expand the
library. There you will see subclasses of the library which are the building
blocks of PROMOT. (i.e. compound, gate, not, struct-adapter)

The main subclasses of the PROMOT library to build a logical model are as
follows:

(a) compound: They are used to model logical states. compound contains
some common molecular classifications of certain species in a signal-
ing network. These can be viewed by expanding the compound class
by clicking on its corresponding handle button (i.e. adapter (adapter
protein), gtpase, kinase, phosphatase, receptor, transfactor (transcrip-
tion factor) etc.). Note that compounds can not be directly connected,
and you need (at least) one element of the class gate between any two
compounds. Examples will be discussed in section 5.1.

6typically at: /usr/local/promot/promot/kb/SignalTransd/structure/
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(b) gate: gates include the logical connecting components of the network
for describing certain reactions and are based on common boolean logic
and operators.

i. activ: A single arc denoting the influence of one element on an-
other is made via an activ (activating gate). If the effect is negative,
a not should be additionally included (see Figure 3(a) and 3(b)).

ii. and: The and gate allows the connection of 2 or more compounds
together and follow the “all or nothing” normal logic of an and gate
(see Figure 3(e)). We have built and gates that allow up to 6 input
species, however larger gates can also be built.

iii. boundary: It is the superclass for drain and source.
source: This class represents an input to a compound (see Fig-
ure 3(g)). All compounds that have no prior activating (or inhibit-
ing) reaction to them can be connected to a source component.
drain: It represents the output of a compound (see Figure 3(h)).

iv. gate-2: This is a superclass for some other gates like and and or.
You should not use gate-2 directly in your models.

v. or: A logic or connection can easily be implemented using activ
(see Figure 3(c), the inclusion of nodes is described in section 5.1
and Figure 6(a)), alternatively an or gate (Figure 3(d)) can be used
to allow the connection of several species to one gate, if e.g. one
wants to replace an and gate by an or gate.

vi. somehow: These gates act as a gate where the connection is not
completely clear and allow to model incomplete truth tables. [3]

(c) not: The not class is used to represent an inhibitory effect on a com-
pound. It must be used in place before any activating reaction gate (i.e.
before an active, or, and or somehow gate, see Figures 3(b) and 3(f)).

(d) struct-adapter: The adapters allow to connect a node to a terminal. The
struct-adapter class should not be integrated into a model itself. There
are two different adapter-types available:
The struct-adapter-compound should be used to connect a compound
terminal to the outer module (see Figure 3(i)).
The struct-adapter-gate should be used to connect gates to the sur-
roundings (see Figure 3(j)).

The class struct-model is also saved in the .MDL file for the library. It should
be used as superclass for modules to identify them as logic ones. The Expla-
nation how you can add a superclass will follow soon.

12



(a) ACTIV (b) NOT (c) OR (using activ) (d) OR (using a gate)

(e) AND (f) Combination of activations and in-
hibitions in an AND gate

(g) SOURCE

(h) DRAIN (i) STRUCT-ADAPTER-
COMPOUND

(j) STRUCT-ADAPTER-
GATE

Figure 3: Implementation in PROMOT of basic logical connections.
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5 The VISUAL EDITOR

Besides the possibility of building a model in .MDL code, PROMOT provides
visual editing via the PROMOT VISUAL EDITOR. From now on it is simply
called VISUAL EDITOR.

We are going to be building the model represented in Figure 4 which corre-
sponds to the ‘toymodel’ (described in [4]). This model represents a simple
modular example of a cell signal transduction pathway. There are three main
modular levels in toymodel:

(a) Whole model represents the overlay of the whole cell and two extracel-
lular inputs representing different possibilities of ligand binding to the
cells receptors.

(b) Cell comprises the main inter-cellular signal transduction reactions that
occur upon ligand binding to the cells receptors, down to (and including)
the nuclear phenomena.

(c) Nucleus represents the subsequent events that lead up to gene transcrip-
tion, expression or proliferation

• Click on the cell module of the toymodel and once it is highlighted right-
click on it to view the context-menu. Then select Visual Edit. This
brings up a new window in PROMOT displaying the VISUAL EDITOR.
Alternatively you can also double-click to the module in the BROWSER

tree.

• There are two main areas to the VISUAL EDITOR

(a) The left area including tabs named Modules, Terminals and Su-
perclasses.

(b) The canvas or template area on the right where the model is built.

• To configure the VISUAL EDITOR for logical models you have to add
an additional superclass to your model. To do so click on the tab Super-
classes in the left area of the VISUAL EDITOR. Now you can drag with
the mouse from the struct-model class from the BROWSER tree into the
Superclasses tab of the VISUAL EDITOR.

• Now you have to reopen the VISUAL EDITOR. Select Model > Close
from the VISUAL EDITOR menu and click on Save in the appearing dia-
log. Reopen the cell module by double-clicking on it in the BROWSER7.

7the class cell appears twice in the BROWSER-tree under its two superclasses. It doesn’t matter
which one you edit, it’s the same.
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Figure 4: Toymodel described in [4]. See a larger version in the Figure 13 in the appendix.

The VISUAL EDITOR has now adapted functionality for logical models
and you should see an additional toolbar (see Figure 5). Repeat this pro-
cedure of adding the superclass struct-model with the whole-model and
nucleus.

• The two dots (LED lamps) at the lower left show some information,
what the editor is currently doing. The status is encoded by color. The
dot for the editor can be in the following states:

– red, reloading or doing garbage collection
– light-green, running (calculating something)
– dark-green, the editor is idle (out-of-work)

In case of a red dot, you should wait until the reload or garbage collec-
tion is finished. Otherwise inconsistent states can occur.
The dot for the checker system can be in three different states:

– light-green, the checker is still validating the structure
– dark-green, the structural check is finished
– yellow, the checker is switched off
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Figure 5: BROWSER with loaded struct-library and toymodel and VISUAL EDITOR for cell module
configured for logical models

5.1 The building process

(a) To build the model you just drag and drop components from the struct-
library in the BROWSER-tree into the canvas part of the VISUAL EDI-
TOR. For instance, in our example of the cell module we have a receptor
named r1. To add this receptor:

• Click on the receptor compound in the BROWSER tree and drag it
onto the cell canvas.
• To rename the component press the “Space” key, type the new name

and press “Enter” to confirm.
• A red box appears around the compound. It’s part of a checker-

system for logical models, which will be explained in section 5.3.
Only so much at this point: If you go with the mouse over the mod-
ule that has a box a tool-tip appears, which shows you the problem.
This might help you to design structurally correct models.

(b) Now click on the Modules tab. There you should later see the building
components of the model. At the moment there is only the receptor.

• If you want to have a second receptor in your model you can drag
it from here to the canvas.
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• You can simply drag and drop a desired component from the BROWSER

tree into the Modules tab area of the VISUAL EDITOR.
• If you would like that component to always load upon opening of

the VISUAL EDITOR by default, click on that component within
the VISUAL EDITOR module, then right-click and select Default
Class.
• If you want to delete a certain component from loading by default

into the VISUAL EDITOR select the component, right-click and se-
lect Remove Default.
• Finally, if you want to delete the component from the Modules tab

area altogether, select the component, right click and select Delete.

(c) Next connect compounds together in the network by different gates. Let
us for example make the connection from r1→ a1:

• Drag an adapter (protein) onto the canvas and rename it to a1.
• Drag also an activ gate onto the canvas and connect the terminal (the

little blue circle) of r1 to the input terminal of the active by dragging
a line between the terminals. A linknode is added to the connection
automatically, because every compound should have an input and
an output. Now drag a connection from the output terminal of the
activ to a1 in the same way. A linknode is added again and is placed
on the compound terminal.
• Our first connection has been made. You should have something

similar to Figure 6(a).
• You can achieve this activation of a1 by r1 also by using a shortcut.

Delete the activ gate (there are two possibilities: Either select the
module and press delete on your keyboard or right-click the module
and select Delete from the context-menu). Click on the Activa-
tion-button in the upper right toolbar of the VISUAL EDITOR. Now
you can use a shortcut. Connect the terminal of r1 to the terminal
of a1 by dragging a line from one to the other. An active has been
inserted between the two compounds automatically. Furthermore,
on every compound a linknode was added.
• By using the ShortCut-mode the inserted modules are named au-

tomatically. If you want to use other names you can remove the
edges, rename the module and reconnect. You can’t rename con-
nected modules. But the names of gates can be chosen freely and
have no importance.
• There is a second shortcut for inhibition available in the toolbar.

Delete the active again. Click on the Inhibition-button and drag a
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connection from r1 to a1. You should have something similar to
Figure 6(b).

(a) activation (b) inhibition

Figure 6: First steps in setting up the toymodel. The final model is displayed in 7.

(d) You can move any of the elements around on the canvas, for visually
more appealing positions, by selecting it and moving it with either your
mouse, or with the arrow keys from your keyboard8.

(e) Like in the BROWSER of PROMOT you can undo/redo the editing ac-
tions you’ve done in the VISUAL EDITOR. There are three possibilities:

• Click on Edit > Undo / Redo
• Press “Control”+ “Z” or “Control” + “Y” respectively or
• click on the Undo/Redo buttons in the toolbar

How many steps can be undone can be chosen in Options > Customize
Undo/Redo.

(f) To build the cell module you would need a larger canvas than you have
at the moment. You can set the size by selecting Edit > Set Module
Size from the VISUAL EDITOR menu. A width of 800 and a height of
900 should be enough for the cell module.

(g) Now let us add the second receptor, r2, a2, and the notr1 r2 a2 and
gate:

i. Drag a not gate onto the canvas9.
ii. Drag an and-2 gate onto the canvas and name it notr1 r2 a2.

8larger steps can be achieved by holding the shift key and pressing the corresponding arrow key
9as for the gates, the name of the not elements have no relevance
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iii. Drag another adapter onto the canvas and name it a2.
iv. Drag another receptor onto the canvas and name it r2.

(h) Connect them together by dragging a line with the mouse from the r2
terminal to one of the two inputs of the and-2 gate.

(i) As mentioned before the not gate is used to represent an inhibitory ef-
fect. Drag a line from the input of the not to the terminal of r1. Then
drag a line from the not output terminal to the other input of the and-2
gate.

(j) Now click on the output terminal of the and-2 gate and drag a line to the
a2 terminal.

(k) Continue building the cell model in this fashion until it looks like the
cell module in Figure 7, remembering to name the elements before
connecting them. Also, be sure to save the model through the VI-
SUAL EDITOR periodically by selecting Model > Save. In the mod-
ules palette of the VISUAL EDITOR you can see which classes are used
for the cell module. You can’t visually distinguish between a reservoir
and a compound. k3r for example is a reservoir. For comparison you
can find the complete toymodel in the knowledge-base of PROMOT in
“/usr/local/promot/promot/kb/SignalTransd/structure/toymodel tutorial”.

(l) Now you need to add the input and output components to the model. If
this were a single (non-modular) model one could use just the source and
drain library components, however, because we want our input compo-
nents to come from another module we need to tell PROMOT this and
add a terminal structure input. To do this:

i. Click on the r1 receptor and then right click and select Connect
Terminals > Propagate input. Normally you will propagate free
terminals, but you can also propagate connected terminals like in
this case. The corresponding struct-adapter is added automatically.

ii. When you have added both inputs to the model save the model
through the VISUAL EDITOR as explained earlier and then close it
by clicking on the X on the upper-right hand corner. Do not worry
about the connection to the nucleus module at this point (we will
get back to that).

(m) Now back in the BROWSER select the cell module and save it to its
own file by selecting File > Save Selected Classes and overwriting the
cell.mdl file you first created. This makes it easier, later in time, to load
the file independently if so desired.

(n) Next, select the nucleus module and open it in the VISUAL EDITOR.

19



Figure 7: Building a model: The module cell opened in the VISUAL EDITOR
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(o) Build the model as done in previous steps according to the nucleus mod-
ule seen in Figure 4 being sure to save the file in both the VISUAL EDI-
TOR and the BROWSER.

(p) Next, click on whole model and open it in the VISUAL EDITOR and add
the two source elements lig1 and lig2.

(q) Now we need to connect the cell module to this whole model module.
To do this:

i. Within the BROWSER click on the cell module and drag and drop
it to the canvas of the VISUAL EDITOR (as done previously to add
library components to the VISUAL EDITOR).

ii. Then connect the input terminal connection from lig1 to the first
input of the cell and the input terminal connection from lig2 to the
second input of the cell.

iii. Save the file in the VISUAL EDITOR as well as in the BROWSER

You will not see the circular icon of the cell that is in Figure 4, but
rather just a white box with the modular name cell typed in blue
font on its inside. Until you design your own icon to implement
into the code this is what it will look like, and this topic is beyond
the scope of this tutorial.

(r) Next we need to add the nucleus module to the cell module.

(s) As done before, open the cell module to the VISUAL EDITOR from the
BROWSER.

(t) Then drag the nucleus module from the BROWSER into the cell canvas
of the VISUAL EDITOR and connect the corresponding connections to
its input terminal connections. (In our case: k3p2 to nucleus input2 and
k3p1 to nucleus input1).

(u) Save the file in both the VISUAL EDITOR and BROWSER.

(v) Finally, save the whole superclass toymodel again with all subclasses
selected. (Click on the toymodel, click on Edit > Select > Select Sub-
classes, and then click on File > Save Selected and overwrite the toy-
model.mdl file saved previously.

5.2 Properties and Documentation
While building logical models there are different properties that are often useful for
describing the characteristics of the model. PROMOT has implemented some of

21



these concepts into properties of the model, these properties are considered “vari-
ables”. These properties include the following:

1. conf: Degree of Confidence. This variable is used to set a level of how con-
fident or well supported a certain reaction is. The value 1 being the most
established.

2. defval: Default Value. This is to set the logical default value of a compound,
and in this case since we are using binary logical models they can be set as
either 1 or 0. By default PROMOT sets the default value to ‘nothing’.

3. ignore in export This parameter determines whether the gate is exported to
the CellNetAnalyzer. Allowed Values 0 (exported) or 1 (ignored in export),
default 0.

4. logexcl: Logical exclude. The default value of this variable is 0, it can be
changed to 1 if a reaction shall only be considered in the analysis of the inter-
action graph but excluded in the logical analysis.

5. map number Parameter determining the map in CellNetAnalyzer. Should be
a positive int, default is 1.

6. monotone Parameter defining the gate to be monotone. Allowed Values 0
(non monotone) or 1 (monotone), default 0.

7. textbox type Parameter determining if the textbox in CellNetAnalyzer is ed-
itable (1), not-editable (2) or non-visible (3). The default value is 1.

8. time: Time-Scale. This variable is the parameter determining the time-scale
for the reactions. The value 1 being the default value and earliest (or fastest)
time event. Bigger values indicate slower events.

9. a: Level of Activation. This parameter has a default value of 1, and can be
modified to encode multilevel logical operations. For example, in the toy-
model (see Figure 4), tf1 could reach a level 2 if both k3p1 and k3p2 are
active. This would be set up in PROMOT by setting the output of the and gate
to a=2 (see Figure 8).

These properties can be changed in the VISUAL EDITOR of PROMOT by select-
ing the specific reaction gate, then click right on it and select Edit Details via the
context-menu.

The construction of signaling networks often leads to large complex models.
One of the most important things to do while building these models is to keep track
of the references of where the data supporting the architecture of these models is
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Figure 8: Properties like the multilevel variable a can be edited via the ‘Details’-
Dialog in the context-menu.
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coming from. PROMOT allows this to be implemented while building the model in
the VISUAL EDITOR.

1. In the VISUAL EDITOR select the reaction of your choice.

2. Right-click on the reaction and choose Edit Details.

3. Under ‘Slot Properties’ you can find an area labeled Documentation, click in
the text field and type the desired documentation. While exporting the model
to the CELLNETANALYZER the documentation will be written into separate
files named ’metabolites notes’ and ’reaction notes’. Because the model is
flattened the documentation of complex modules (e.g. or and and-2-2 gates)
will be written into the ’reaction notes’ for the included nodes.

4. When you are finished click on the ‘Close’-Button or select in the menu of the
dialog Model > Close. A save dialog appears, press the ‘Save’-Button. Now
the module with the new properties exists in the running PROMOT system.

5.3 A structure checker for logical models
You should have noticed the colored boxes around modules, which appear and dis-
appear while editing the model. There are three types of them. The red box indicates
an open terminal, which should be connected by an edge to another terminal. There
can also be white boxes, they show a connection-error, e. g. connected compounds
without a gate in-between. Turquoise boxes show deprecated classes. There can
be more than one problem to a module but only the box with the highest priority
is shown. In the tool-tip of the module you can see all known problems with the
assigned color (see Figure 9). If you solve the problem the box disappears.

You can switch the checker off by disabling the appropriate check box in the
menu Options > Check For Missing Edges And Wrong Connections, but we
suggest to switch the checker on before you export your model to ensure its struc-
tural correctness.

5.4 Automatic layout of modules and models
The layout of graphical components (e.g. compounds, gates and modules) is a key
role in the understanding of the structure of the whole model. Methods for auto-
matic layout can be useful when no initial layout is available (e.g. SBML import)
or the given network layout should be re-arranged. The VISUAL EDITOR provides
different methods for the automatic layout of individual modules and whole models.
All available layouts can be found in the menu Layout of the VISUAL EDITOR.
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Figure 9: Structure checker: the problems are shown in the tool-tip

In the following, the basic and advanced layout techniques and their characteris-
tics are described briefly. Note that basic layout techniques do not have an option
settings dialog, whereas advanced layout techniques have such dialogs.

• Basic layouts

– Grid Layout
The components of the module are placed on a grid.

– Radial Layout
The components of the module are placed on a circle.

– Random Layout
The components of the module are placed randomly.

• Advanced layouts

– Spring Layout
The components of the module are placed according to the force-directed
layout approach. The generated layouts are symmetric, having equal
edge lengths and looking somehow organic. So they are suitable for
biological models.

– Simple Compound Layout (= Local Compound Graph Layout)
The Simple Compound Layout generates for each submodule of the
model a separate layout independent from global constraints and depen-
dencies. Before starting a layout process you can choose the layout tech-
nique to be used (Grid Layout, Radial Layout, Random Layout, Spring
Layout). The Simple Compound Layout is faster than the Compound
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Spring Layout but the layout quality is often poorer than the quality of
layout generated with the Compound Spring Layout.

– Compound Spring Layout (= Global Compound Graph Layout)
The Compound Spring Layout is based on the Spring Layout and cal-
culates the layout of a model by considering the global connections and
dependencies between the modules. Therefore the layout quality is bet-
ter than the quality of the layout generated with the Simple Compound
Layout (less edge-node-crossings and edge-edge-crossings).

When the layout of a whole structured model should be generated, you can use
the methods Simple Compound Layout or Compound Spring Layout. These
layout methods are specialized in the handling of complex structured models.

You can control the quality of the advanced layouts by using a layout settings
dialog (see Figure 10 for an example). For the Spring Layout and the Compound
Spring Layout you can find further settings in the dialog like ’Direction of the
Layout’ or ’Place Link Nodes on Compounds’. These options are dedicated to
further semantic information provided by the model (e.g. edge directions) which
can be integrated in the layout process. As an example Figure 11 shows the result
of the Spring Layout of the cell module from the toymodel example considering
the edge direction.

Figure 10: Settings dialog of the Spring Layout.
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Figure 11: The result of the Spring Layout for the cell module. Notice that edge
directions are considered and link nodes are placed on compounds to improve the
layout quality.
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6 VISUAL EXPLORER

The VISUAL EXPLORER is an additional GUI component of PROMOT. To get to
the VISUAL EXPLORER do the following:

• Within the left panel BROWSER select the model of your choice.

• Right-click on the model and from the context-menu select Visual Explorer.
Alternatively, select in the menu of the PROMOT BROWSER View > Visual-
Explorer.

• While loading an information window appears (time to load depends on the
size of the network).

• The VISUAL EXPLORER will pop-up.

The VISUAL EXPLORER is used for creating and manipulating different graphi-
cal representations of a network. For this purpose, the concept of Visual Scenarios
is introduced. A visual scenario is a set of visual mapping functions for changing
visual properties of the network (layout, display) and defines adequate user inter-
actions. Therewith, convenient and fast switching between different visual settings
is feasible. Almost all visual properties of the network and its parts can be altered,
including color, size and line type.

For setup a visual scenario:

• Select in the menu of the VISUAL EXPLORER Edit > Edit Scenario. . . .

• Select a new scenario in the Popup-Menu.

• Or alter the current scenario by clicking on the ‘Edit’-Button.

6.1 Properties
Properties like the multilevel variable a or the visibility variable can be edited in the
‘Details’-Dialog (how to use the ‘Details’-Dialog see the section 5.2). The default
value of the parameter a (level of activation), is 1, and can be modified to encode
multilevel logical operations. The default value of the parameter ContentVisible
(visibility of the module content), is 1 (visible), and can be used to display or hide
the content of the module for unclutter the representation.

The following examples illustrate the process of designing a biological moti-
vated representation of the model, and the resulting map is depicted in Figure 2
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(right side). Elements of the class not are hidden, and the corresponding informa-
tion (that a certain influence has a negative effect) is coded in the color of the line.
Another class specifically treated is the reservoir. Elements of this class are used
when several pools of a molecule are considered. This is a common situation, for
example, if two subsets of a certain molecule with distinct properties, typically a
different localization in the cell or different regulation, are to be modeled. For ex-
ample, in the toy model there are two pools for the kinase k3, k3p1 and k3p2, which
are regulated differently. In this case, a ’reservoir’ is included which is required for
the activation of both pools. This allows simultaneous knock-outs of both pools, but
this is also a mathematical entity without a clear biological interpretation. Hence,
elements of the class reservoir are automatically hidden, and the line connecting
them to the corresponding pools is dashed. In this way, the mathematical informa-
tion (there is a reservoir present) is maintained in the graphical representation, but
coded in such a way that it is not confused with other kind of information.

Figure 12: Different visual scenarios. (Left) Scenario towards a biological moti-
vated representation of the model. The border of cell and nucleus are highlighted,
connection lines are curved and the protein type is encoded by different colors.
(Right) Scenario towards a more abstract representation. Proteins have a uniform
color, connection lines are orthogonalized, and the border of cell and nucleus are
de-emphasized to draw the attention to both logical operations and connections.

6.2 Visual Scenarios
In the VISUAL EXPLORER different scenarios are predefined, e.g. “Logical Net-
work”, “Connectivity” or “Interaction Distance”. These common scenarios, also

29



called in PROMOT “global scenarios” have the following functionality:

• Logical Network
The network representation will be adapted towards a more logical meaning
which focuses on logical operations and connections between operators and
network elements (for a typical example see Figure 12(b)).

• Connectivity
Connectivity is a property of the graph topology and is used for analysis in
graph theory. Here, each entity (or node) is ranked by a connectivity value
based on the link structure (incoming and outgoing links). The connectivity
value is encoded by a color gradient.

• Interaction Distance
Interaction distance defines the distance from an entity (or node) in focus to
another entity in the network. The distance is given by the link structure,
e.g. two entities which are directly connected have an interaction distance of
1. The distance value is encoded by color. This scenario is interactive that
means the user has to set the focus or foci by clicking with the mouse device
on one or more entities in the network.

Furthermore, the VISUAL EXPLORER is more appealing for publication, expor-
tation, and printing.
For an overview of navigation pattern, shortcuts and modifiers, please refer to ta-
ble 1 in the appendix.

30



7 Importing and Exporting Logical Models
There is currently no standard for the modeling, visualization and storage of log-
ical networks (note that SBML only supports kinetic models). Recently, there
has been an initiative to define a standard for boolean networks (GinML, see [5])
which is, however, still not established. Therefore, we have implemented import
and export functionality using a format which is also readable by the analysis tool
CELLNETANALYZER (CNA) [3]. New formats, however, can be implemented
easily.

For the export of the logical PROMOT model including the graphics file and the
equations, open the model of your choice in the VISUAL EXPLORER (as discussed
previously). Then select in the menu of the VISUAL EXPLORER Model > Export
> Output To CELLNETANALYZER and save the model to the directory of your
choice. For obtaining the CELLNETANALYZER, go to
http://www.mpi-magdeburg.mpg.de/projects/cna/cna.html.
In order to perform analyses as those from[3], do not to check the Export Bound-
ary Reactions in the ‘Export’-Dialog. Besides, the Simple Name option will export
quite compact names. To import models in CELLNETANALYZER format select in
the BROWSER File > Import > Import Logical Model.
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8 Appendix

8.1 Example Model

8.2 VISUAL EXPLORER Shortcuts and Modifiers

Operation Shortcut Description

Menus
Open node menu Click right button on entity Opens the context menu for nodes
Open edge menu Click right button on entity Opens the context menu for edges

Mode: Interactive Zoom
Zoom in Hold down left button + Drag right Zoom in the network
Zoom out Hold down left button + Drag left Zoom out the network
Pan Hold down left button + Ctrl + Drag Move (pan) the entire canvas

Mode: Hierarchy Zoom
Zoom in Click left button on entity Zoom in to focused entity in hierarchical steps
Zoom out Click left button on entity Zoom out to focused entity in hierarchical steps
Fit network on screen Click left button + Shift Zoom out the entire network to fit on screen
Pan Hold down left button + Ctrl + Drag Move (pan) the entire canvas

Mode: FishEye Zoom
Zoom in Click left button on entity Enlarge focused entity, shrink all other entities
Zoom out Click left button on entity + Shift Shrink focused entity, enlarge all other entities
Pan Hold down left button + Ctrl + Drag Move (pan) the entire canvas

Mode: Focus Zoom
Zoom to Click left button on entity Minimal zoom to focused entity
Pan Hold down left button + Ctrl + Drag Move (pan) the entire canvas

Mode: Detail+Overview
Pan Click left button on gray box + Drag Move (pan) the entire canvas
Zoom Click left button on handle of gray box + Drag Zoom in or out the network

Mode: Node Editing
Move Click left button on entity + Drag Move entity inside bounds of parent
Resize (all) Click left button on handle + Drag Scale entity including children and label
Resize (bounds) Click left button on handle + Shift + Drag Resize only bounds of entity, keep size of children and label
Pan Hold down left button + Ctrl + Drag Move (pan) the entire canvas

Mode: Edge Editing
Move handle Click left button on handle + Drag Move edge handle
Add handle Click right button on edge for context menu Add edge handle
Delete handle Click right button on edge for context menu Remove edge handle
Delete all handles Click right button on edge for context menu Remove all edge handles
Pan Hold down left button + Ctrl + Drag Move (pan) the entire canvas

Mode: Scenario ’Interaction Distance’
Show Int Dist Click left button on entity Show Interaction Distance for focused entity
Show Int Dist (multi) Click left button on entity + Shift Show Interaction Distance for previous and focused entity
Show Int Dist (path) Click left button on two entities + Ctrl Show Interaction Distance for all entities on the shortest path

Table 1: Shortcuts and modifiers used in the Visual Explorer.
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Figure 13: Toymodel described in [4].34
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